创新路
我们一直在努力

配置基于接口划分vlan

配置基于接口划分vlan

一、组网需求

      S1作为汇聚层交换机, S2、 S3作为PC电脑的网关设备下连PC电脑或HUB交换机;

      PC1属于vlan2直连SW2,网关为vlanif 2接口地址192.168.2.1/24;

      PC2属于vlan 3通过hub接入到SW2,网关为vlanif3接口地址192.168.3.1/24;

      PC3和PC4属于vlan 4直连S3,网关为 vlanif 4接口地址192.168.4.1/24;

      通过配置实现各PC电脑之间互访。

1584599119510959.png

二、配置思路

      1.  创建VLAN并将连接用户的接口加入VLAN,实现不同业务用户之间的二层流量隔离;

      2.  配置各PC电脑的网关IP地址,实现相同业务用户之间三层互通;

      3.  配置静态路由实现不同业务用户之间三层互通。

三、SW2配置

1.创建vlan

<SW2> system-view                                      //进入系统模式

[SW2] vlan batch 2 to 3                              //批量创建vlan 2和3

[SW2] vlan 5                                           //新建vlan 5

[SW2-vlan5] quit                                       //退出vlan 5

2.接口加入到相应vlan

[SW2] interface GigabitEthernet 0/0/3                 //对接PC1

[SW2-GigabitEthernet0/0/3] port link-type access      //链路类型为access

[SW2-GigabitEthernet0/0/3] port default vlan 2    

[SW2-GigabitEthernet0/0/3] quit                      

[SW2] interface GigabitEthernet 0/0/2                 //对接PC2

[SW2-GigabitEthernet0/0/2] port link-type access

[SW2-GigabitEthernet0/0/2] port default vlan 3  

[SW2-GigabitEthernet0/0/2] quit  

[SW2] interface GigabitEthernet 0/0/1                 //对接SW1              

[SW2-GigabitEthernet0/0/1] port link-type access

[SW2-GigabitEthernet0/0/1] port default vlan 5

[SW2-GigabitEthernet0/0/1] quit

3.配置ip地址作为PC电脑的网关IP地址

[SW2]  interface Vlanif 2                               //系统视图下进入三层vlanif 2接口

[SW2-Vlanif2] ip address 192.168.2.1 255.255.255.0     //配置PC1的网关地址

[SW2-Vlanif2] quit                                     //退出vlanif接口视图

[SW2] interface Vlanif 3

[SW2-Vlanif3] ip add 192.168.3.1 24  

[SW2-Vlanif3] quit

4.配置ip地址实现SW2和SW1互联

[SW2] interface Vlanif 5

[SW2-Vlanif5] ip address 192.168.5.2 24               //互联接口IP地址

[SW2-Vlanif5] quit

5.配置静态路由,为SW2下PC网段出去指路

[SW2] ip route-static 0.0.0.0 0.0.0.0 192.168.5.1 //配置默认路由出去,下一跳为对端SW1的接口地址192.168.5.1

6.配置完成后保存配置

<SW2> save

四、SW3配置

1.创建vlan

<SW3> system-view                                            //进入系统模式

[SW3] vlan 4                                                 //新建vlan 4

[SW3-vlan4] quit                                             // 退出vlan 4

[SW3] vlan 5

[SW3-vlan5] quit

2.接口加入到相应vlan

[SW3] interface Ethernet 0/0/1                           //接PC电脑

[SW3-Ethernet0/0/1] port link-type access                //链路类型为access  

[SW3-Ethernet0/0/1] port default vlan 4                

[SW3-Ethernet0/0/1] quit  

[SW3] interface GigabitEthernet 0/0/1                   //对接SW1

[SW3-GigabitEthernet0/0/1] port link-type access      //链路类型为access

[SW3-GigabitEthernet0/0/1] port default vlan 5

[SW3-GigabitEthernet0/0/1] quit

3.配置IP地址作为PC电脑的网关IP地址

[SW3] interface Vlanif 4                            //系统视图进入vlanif4三层接口

[SW3-Vlanif4] ip address 192.168.4.1 24          //配置PC3和PC4的网关地址

[SW3-Vlanif4] quit

4.配置ip地址实现SW3和SW1互联

[SW3] interface Vlanif 5

[SW3-Vlanif5] ip address 192.168.5.3 24                //互联接口IP地址

[SW3-Vlanif5] quit

5.配置静态路由,为SW3下PC网段出去指路

[SW3] ip route-static 0.0.0.0 0.0.0.0 192.168.5.1    //配置默认路由出去,下一跳为对端SW1的接口地址192.168.5.1

6.配置完成后保存配置

<SW3> save

五、SW1配置

1.创建vlan

<SW1> system-view                                        //进入系统模式

[SW1] vlan 5                                             //新建vlan 5

[SW1-vlan5] quit                                         //退出vlan5模式

2.接口加入到相应vlan配置

[SW1] interface GigabitEthernet 0/0/2                   //对接SW2

[SW1-GigabitEthernet0/0/2] port link-type access       //链路类型为access

[SW1-GigabitEthernet0/0/2] port default vlan 5         //透传vlan5

[SW1-GigabitEthernet0/0/2] quit                        //退出接口GE0/0/5

[SW1] interface GigabitEthernet 0/0/24                 //对接SW3

[SW1-GigabitEthernet0/0/24] port link-type access

[SW1-GigabitEthernet0/0/24] port default vlan 5

[SW1-GigabitEthernet0/0/24] quit  

[SW1] interface  GigabitEthernet 0/0/1                //对接R路由器  

[SW1-GigabitEthernet0/0/1] port link-type access

[SW1-GigabitEthernet0/0/1] port default vlan 5

[SW1-GigabitEthernet0/0/1] quit

3. 配IP地址,作为对接SW2、SW3及R路由器的互联接口地址                              

[SW1] interface Vlanif 5                              //进入三层接口vlanif5

[SW1-Vlanif5] ip address 192.168.5.1 24            //配置ip地址

[SW1-Vlanif5] quit                                     //退出vlanif 5

4.配置静态路由

[SW1] ip route-static 192.168.2.0 255.255.255.0 192.168.5.2

[SW1] ip route-static 192.168.3.0 255.255.255.0 192.168.5.2

[SW1] ip route-static 192.168.4.0 255.255.255.0 192.168.5.3

[SW1] ip route-static 0.0.0.0 0.0.0.0 192.168.5.4

5.配置完成后保存配置

<SW1> save

未经允许不得转载:天府数据港官方信息博客 » 配置基于接口划分vlan

客官点个赞呗! (0)
分享到:

评论 抢沙发

评论前必须登录!

天府云博 - 做有态度的开发&运维&设计学习分享平台!

联系我们百度云主机